πι

Ο αριθμός π (συμβολίζεται διεθνώς με το ελληνικό γράμμα π) είναι μια μαθηματική σταθερά που ορίζεται ως ο λόγος της περιφέρειας προς τη διάμετρο ενός κύκλου και είναι – με ακρίβεια οκτώ δεκαδικών ψηφίων – ίσος με 3.14159265.

Ένας αριθμός που έχει εμπνεύσει, προβληματίσει και βοηθήσει τόσους ανθρώπους, σχεδόν όσα και τα ψηφία του.

Οι Πυθαγόρας ο Σάμιος, James Gregory, Αρχιμήδης ο Συρακούσιος, Απολλώνιος ο Περγαίος, Κλαύδιος Πτολεμαίος, Sir Isaac Newton, Leonard Euler, Johann Carl Friedrich Gauss, Srinivasa Ramanujan, Madhava of Sangamagrama, Liu Hui, Rabbi Nehemiah, Zu Chongzhi, Gottfried Wilhelm Leibniz, Aryabhata, Abraham Sharp, William Shanks, John von Neumann, (εσύ κι εγώ) είναι ελάχιστοι από αυτούς που εμπλέκονται με τον αριθμό Πι.

Ο Πλάτων εφήυρε (και ένας σύγχρονος μαθηματικός επέκτεινε) τον εξής μνημονικό κανόνα για να θυμάται τα πρώτα ψηφία του Πι:

Ἀεί ὁ Θεός ὁ Μέγας γεωμετρεῖ, τό κύκλου μῆκος ἴνα ὁρίσῃ διαμέτρῳ, παρήγαγεν ἀριθμόν ἀπέραντον, καί ὄν, φεῦ, οὐδέποτε ὅλον θνητοί θά εὐρῶσι

Οι James Gregory και Gottfried Wilhelm Leibniz εφήυραν την πιο απλή formula υπολογισμού του Πι, αποδεικνύοντας ότι:

PiFormula
Η παραπάνω formula σε ψευδογλώσσα αναπαρίσταται ως εξής:

ΑΛΓΟΡΙΘΜΟΣ ΠιΦόρμουλα
 ΠΙ  0
 flag  ΑΛΗΘΗΣ 
 ΔΙΑΒΑΣΕ Ν !Ένας πολύ μεγάαααλος ακέραιος... 
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν ΜΕ_ΒΗΜΑ 2 
  ΑΝ flag = ΑΛΗΘΗΣ ΤΟΤΕ 
   ΠΙ  ΠΙ + 1/i 
  ΑΛΛΙΩΣ 
   ΠΙ  ΠΙ - 1/i 
  ΤΕΛΟΣ_ΑΝ 
  flag  ΟΧΙ flag 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
 ΕΜΦΑΝΙΣΕ ΠΙ*4 
ΤΕΛΟΣ ΠιΦόρμουλα

 

Αντί επιλόγου…

3 . 1 4 1 5 9 2 6 5 3 5 8 9 7 9 3 2 3 8 4 6 2 6 4 3 3 8 3 2 7 9 5 0 2 8 8 4 1 9 7 1 6 9 3 9 9 3 7 5 1 0 5 8 2 0 9 7 4 9 4 4 5 9 2 3 0 7 8 1 6 4 0 6 2 8 6 2 0 8 9 9 8 6 2 8 0 3 4 8 2 5 3 4 2 1 1 7 0 6 7 9 8 2 1 4 8 0 8 6 5 1 3 2 8 2 3 0 6 6 4 7 0 9 3 8 4 4 6 0 9 5 5 0 5 8 2 2 3 1 7 2 5 3 5 9 4 0 8 1 2 8 4 8 1 1 1 7 4 5 0 2 8 4 1 0 2 7 0 1 9 3 8 5 2 1 1 0 5 5 5 9 6 4 4 6 2 2 9 4 8 9 5 4 9 3 0 3 8 1 9 6 4 4 2 8 8 1 0 9 7 5 6 6 5 9 3 3 4 4 6 1 2 8 4 7 5 6 4 8 2 3 3 7 8 6 7 8 3 1 6 5 2 7 1 2 0 1 9 0 9 1 4 5 6 4 8 5 6 6 9 2 3 4 6 0 3 4 8 6 1 0 4 5 4 3 2 6 6 4 8 2 1 3 3 9 3 6 0 7 2 6 0 2 4 9 1 4 1 2 7 3 7 2 4 5 8 7 0 0 6 6 0 6 3 1 5 5 8 8 1 7 4 8 8 1 5 2 0 9 2 0 9 6 2 8 2 9 2 5 4 0 9 1 7 1 5 3 6 4 3 6 7 8 9 2 5 9 0 3 6 0 0 1 1 3 3 0 5 3 0 5 4 8 8 2 0 4 6 6 5 2 1 3 8 4 1 4 6 9 5 1 9 4 1 5 1 1 6 0 9 4 3 3 0 5 7 2 7 0 3 6 5 7 5 9 5 9 1 9 5 3 0 9 2 1 8 6 1 1 7 3 8 1 9 3 2 6 1 1 7 9 3 1 0 5 1 1 8 5 4 8 0 7 4 4 6 2 3 7 9 9 6 2 7 4 9 5 6 7 3 5 1 8 8 5 7 5 2 7 2 4 8 9 1 2 2 7 9 3 8 1 8 3 0 1 1 9 4 9 1 2 9 8 3 3 6 7 3 3 6 2 4 4 0 6 5 6 6 4 3 0 8 6 0 2 1 3 9 4 9 4 6 3 9 5 2 2 4 7 3 7 1 9 0 7 0 2 1 7 9 8 6 0 9 4 3 7 0 2 7 7 0 5 3 9 2 1 7 1 7 6 2 9 3 1 7 6 7 5 2 3 8 4 6 7 4 8 1 8 4 6 7 6 6 9 4 0 5 1 3 2 0 0 0 5 6 8 1 2 7 1 4 5 2 6 3 5 6 0 8 2 7 7 8 5 7 7 1 3 4 2 7 5 7 7 8 9 6 0 9 1 7 3 6 3 7 1 7 8 7 2 1 4 6 8 4 4 0 9 0 1 2 2 4 9 5 3 4 3 0 1 4 6 5 4 9 5 8 5 3 7 1 0 5 0 7 9 2 2 7 9 6 8 9 2 5 8 9 2 3 5 4 2 0 1 9 9 5 6 1 1 2 1 2 9 0 2 1 9 6 0 8 6 4 0 3 4 4 1 8 1 5 9 8 1 3 6 2 9 7 7 4 7 7 1 3 0 9 9 6 0 5 1 8 7 0 7 2 1 1 3 4 9 9 9 9 9 9 8 3 7 2 9 7 8 0 4 9 9 5 1 0 5 9 7 3 1 7 3 2 8 1 6 0 9 6 3 1 8 5 9 5 0 2 4 4 5 9 4 5 5 3 4 6 9 0 8 3 0 2 6 4 2 5 2 2 3 0 8 2 5 3 3 4 4 6 8 5 0 3 5 2 6 1 9 3 1 1 8 8 1 7 1 0 1 0 0 0 3 1 3 7 8 3 8 7 5 2 8 8 6 5 8 7 5 3 3 2 0 8 3 8 1 4 2 0 6 1 7 1 7 7 6 6 9 1 4 7 3 0 3 5 9 8 2 5 3 4 9 0 4 2 8 7 5 5 4 6 8 7 3 1 1 5 9 5 6 2 8 6 3 8 8 2 3 5 3 7 8 7 5 9 3 7 5 1 9 5 7 7 8 1 8 5 7 7 8 0 5 3 2 1 7 1 2 2 6 8 0 6 6 1 3 0 0 1 9 2 7 8 7 6 6 1 1 1 9 5 9 0 9 2 1 6 4 2 0 1 9 8 9 3 8 0 9 5 2 5 7 2 0 1 0 6 5 4 8 5 8 6 3 2 7 8 8 6 5 9 3 6 1 5 3 3 8 1 8 2 7 9 6 8 2 3 0 3 0 1 9 5 2 0 3 5 3 0 1 8 5 2 9 6 8 9 9 5 7 7 3 6 2 2 5 9 9 4 1 3 8 9 1 2 4 9 7 2 1 7 7 5 2 8 3 4 7 9 1 3 1 5 1 5 5 7 4 8 5 7 2 4 2 4 5 4 1 5 0 6 9 5 9 5 0 8 2 9 5 3 3 1 1 6 8 6 1 7 2 7 8 5 5 8 8 9 0 7 5 0 9 8 3 8 1 7 5 4 6 3 7 4 6 4 9 3 9 3 1 9 2 5 5 0 6 0 4 0 0 9 2 7 7 0 1 6 7 1 1 3 9 0 0 9 8 4 8 8 2 4 0 1 2 8 5 8 3 6 1 6 0 3 5 6 3 7 0 7 6 6 0 1 0 4 7 1 0 1 8 1 9 4 2 9 5 5 5 9 6 1 9 8 9 4 6 7 6 7 8 3 7 4 4 9 4 4 8 2 5 5 3 7 9 7 7 4 7 2 6 8 4 7 1 0 4 0 4 7 5 3 4 6 4 6 2 0 8 0 4 6 6 8 4 2 5 9 0 6 9 4 9 1 2 9 3 3 1 3 6 7 7 0 2 8 9 8 9 1 5 2 1 0 4 7 5 2 1 6 2 0 5 6 9 6 6 0 2 4 0 5 8 0 3 8 1 5 0 1 9 3 5 1 1 2 5 3 3 8 2 4 3 0 0 3 5 5 8 7 6 4 0 2 4 7 4 9 6 4 7 3 2 6 3 9 1 4 1 9 9 2 7 2 6 0 4 2 6 9 9 2 2 7 9 6 7 8 2 3 5 4 7 8 1 6 3 6 0 0 9 3 4 1 7 2 1 6 4 1 2 1 9 9 2 4 5 8 6 3 1 5 0 3 0 2 8 6 1 8 2 9 7 4 5 5 5 7 0 6 7 4 9 8 3 8 5 0 5 4 9 4 5 8 8 5 8 6 9 2 6 9 9 5 6 9 0 9 2 7 2 1 0 7 9 7 5 0 9 3 0 2 9 5 5 3 2 1 1 6 5 3 4 4 9 8 7 2 0 2 7 5 5 9 6 0 2 3 6 4 8 0 6 6 5 4 9 9 1 1 9 8 8 1 8 3 4 7 9 7 7 5 3 5 6 6 3 6 9 8 0 7 4 2 6 5 4 2 5 2 7 8 6 2 5 5 1 8 1 8 4 1 7 5 7 4 6 7 2 8 9 0 9 7 7 7 7 2 7 9 3 8 0 0 0 8 1 6 4 7 0 6 0 0 1 6 1 4 5 2 4 9 1 9 2 1 7 3 2 1 7 2 1 4 7 7 2 3 5 0 1 4 1 4 4 1 9 7 3 5 6 8 5 4 8 1 6 1 3 6 1 1 5 7 3 5 2 5 5 2 1 3 3 4 7 5 7 4 1 8 4 9 4 6 8 4 3 8 5 2 3 3 2 3 9 0 7 3 9 4 1 4 3 3 3 4 5 4 7 7 6 2 4 1 6 8 6 2 5 1 8 9 8 3 5 6 9 4 8 5 5 6 2 0 9 9 2 1 9 2 2 2 1 8 4 2 7 2 5 5 0 2 5 4 2 5 6 8 8 7 6 7 1 7 9 0 4 9 4 6 0 1 6 5 3 4 6 6 8 0 4 9 8 8 6 2 7 2 3 2 7 9 1 7 8 6 0 8 5 7 8 4 3 8 3 8 2 7 9 6 7 9 7 6 6 8 1 4 5 4 1 0 0 9 5 3 8 8 3 7 8 6 3 6 0 9 5 0 6 8 0 0 6 4 2 2 5 1 2 5 2 0 5 1 1 7 3 9 2 9 8 4 8 9 6 0 8 4 1 2 8 4 8 8 6 2 6 9 4 5 6 0 4 2 4 1 9 6 5 2 8 5 0 2 2 2 1 0 6 6 1 1 8 6 3 0 6 7 4 4 2 7 8 6 2 2 0 3 9 1 9 4 9 4 5 0 4 7 1 2 3 7 1 3 7 8 6 9 6 0 9 5 6 3 6 4 3 7 1 9 1 7 2 8 7 4 6 7 7 6 4 6 5 7 5 7 3 9 6 2 4 1 3 8 9 0 8 6 5 8 3 2 6 4 5 9 9 5 8 1 3 3 9 0 4 7 8 0 2 7 5 9 0 0 9 9 4 6 5 7 6 4 0 7 8 9 5 1 2 6 9 4 6 8 3 9 8 3 5 2 5 9 5 7 0 9 8 2 5 8 2 2 6 2 0 5 2 2 4 8 9 4 0 7 7 2 6 7 1 9 4 7 8 2 6 8 4 8 2 6 0 1 4 7 6 9 9 0 9 0 2 6 4 0 1 3 6 3 9 4 4 3 7 4 5 5 3 0 5 0 6 8 2 0 3 4 9 6 2 5 2 4 5 1 7 4 9 3 9 9 6 5 1 4 3 1 4 2 9 8 0 9 1 9 0 6 5 9 2 5 0 9 3 7 2 2 1 6 9 6 4 6 1 5 1 5 7 0 9 8 5 8 3 8 7 4 1 0 5 9 7 8 8 5 9 5 9 7 7 2 9 7 5 4 9 8 9 3 0 1 6 1 7 5 3 9 2 8 4 6 8 1 3 8 2 6 8 6 8 3 8 6 8 9 4 2 7 7 4 1 5 5 9 9 1 8 5 5 9 2 5 2 4 5 9 5 3 9 5 9 4 3 1 0 4 9 9 7 2 5 2 4 6 8 0 8 4 5 9 8 7 2 7 3 6 4 4 6 9 5 8 4 8 6 5 3 8 3 6 7 3 6 2 2 2 6 2 6 0 9 9 1 2 4 6 0 8 0 5 1 2 4 3 8 8 4 3 9 0 4 5 1 2 4 4 1 3 6 5 4 9 7 6 2 7 8 0 7 9 7 7 1 5 6 9 1 4 3 5 9 9 7 7 0 0 1 2 9 6 1 6 0 8 9 4 4 1 6 9 4 8 6 8 5 5 5 8 4 8 4 0 6 3 5 3 4 2 2 0 7 2 2 2 5 8 2 8 4 8 8 6 4 8 1 5 8 4 5 6 0 2 8 5 0 6 0 1 6 8 4 2 7 3 9 4 5 2 2 6 7 4 6 7 6 7 8 8 9 5 2 5 2 1 3 8 5 2 2 5 4 9 9 5 4 6 6 6 7 2 7 8 2 3 9 8 6 4 5 6 5 9 6 1 1 6 3 5 4 8 8 6 2 3 0 5 7 7 4 5 6 4 9 8 0 3 5 5 9 3 6 3 4 5 6 8 1 7 4 3 2 4 1 1 2 5 1 5 0 7 6 0 6 9 4 7 9 4 5 1 0 9 6 5 9 6 0 9 4 0 2 5 2 2 8 8 7 9 7 1 0 8 9 3 1 4 5 6 6 9 1 3 6 8 6 7 2 2 8 7 4 8 9 4 0 5 6 0 1 0 1 5 0 3 3 0 8 6 1 7 9 2 8 6 8 0 9 2 0 8 7 4 7 6 0 9 1 7 8 2 4 9 3 8 5 8 9 0 0 9 7 1 4 9 0 9 6 7 5 9 8 5 2 6 1 3 6 5 5 4 9 7 8 1 8 9 3 1 2 9 7 8 4 8 2 1 6 8 2 9 9 8 9 4 8 7 2 2 6 5 8 8 0 4 8 5 7 5 6 4 0 1 4 2 7 0 4 7 7 5 5 5 1 3 2 3 7 9 6 4 1 4 5 1 5 2 3 7 4 6 2 3 4 3 6 4 5 4 2 8 5 8 4 4 4 7 9 5 2 6 5 8 6 7 8 2 1 0 5 1 1 4 1 3 5 4 7 3 5 7 3 9 5 2 3 1 1 3 4 2 7 1 6 6 1 0 2 1 3 5 9 6 9 5 3 6 2 3 1 4 4 2 9 5 2 4 8 4 9 3 7 1 8 7 1 1 0 1 4 5 7 6 5 4 0 3 5 9 0 2 7 9 9 3 4 4 0 3 7 4 2 0 0 7 3 1 0 5 7 8 5 3 9 0 6 2 1 9 8 3 8 7 4 4 7 8 0 8 4 7 8 4 8 9 6 8 3 3 2 1 4 4 5 7 1 3 8 6 8 7 5 1 9 4 3 5 0 6 4 3 0 2 1 8 4 5 3 1 9 1 0 4 8 4 8 1 0 0 5 3 7 0 6 1 4 6 8 0 6 7 4 9 1 9 2 7 8 1 9 1 1 9 7 9 3 9 9 5 2 0 6 1 4 1 9 6 6 3 4 2 8 7 5 4 4 4 0 6 4 3 7 4 5 1 2 3 7 1 8 1 9 2 1 7 9 9 9 8 3 9 1 0 1 5 9 1 9 5 6 1 8 1 4 6 7 5 1 4 2 6 9 1 2 3 9 7 4 8 9 4 0 9 0 7 1 8 6 4 9 4 2 3 1 9 6 1 5 6 7 9 4 5 2 0 8 0 9 5 1 4 6 5 5 0 2 2 5 2 3 1 6 0 3 8 8 1 9 3 0 1 4 2 0 9 3 7 6 2 1 3 7 8 5 5 9 5 6 6 3 8 9 3 7 7 8 7 0 8 3 0 3 9 0 6 9 7 9 2 0 7 7 3 4 6 7 2 2 1 8 2 5 6 2 5 9 9 6 6 1 5 0 1 4 2 1 5 0 3 0 6 8 0 3 8 4 4 7 7 3 4 5 4 9 2 0 2 6 0 5 4 1 4 6 6 5 9 2 5 2 0 1 4 9 7 4 4 2 8 5 0 7 3 2 5 1 8 6 6 6 0 0 2 1 3 2 4 3 4 0 8 8 1 9 0 7 1 0 4 8 6 3 3 1 7 3 4 6 4 9 6 5 1 4 5 3 9 0 5 7 9 6 2 6 8 5 6 1 0 0 5 5 0 8 1 0 6 6 5 8 7 9 6 9 9 8 1 6 3 5 7 4 7 3 6 3 8 4 0 5 2 5 7 1 4 5 9 1 0 2 8 9 7 0 6 4 1 4 0 1 1 0 9 7 1 2 0 6 2 8 0 4 3 9 0 3 9 7 5 9 5 1 5 6 7 7 1 5 7 7 0 0 4 2 0 3 3 7 8 6 9 9 3 6 0 0 7 2 3 0 5 5 8 7 6 3 1 7 6 3 5 9 4 2 1 8 7 3 1 2 5 1 4 7 1 2 0 5 3 2 9 2 8 1 9 1 8 2 6 1 8 6 1 2 5 8 6 7 3 2 1 5 7 9 1 9 8 4 1 4 8 4 8 8 2 9 1 6 4 4 7 0 6 0 9 5 7 5 2 7 0 6 9 5 7 2 2 0 9 1 7 5 6 7 1 1 6 7 2 2 9 1 0 9 8 1 6 9 0 9 1 5 2 8 0 1 7 3 5 0 6 7 1 2 7 4 8 5 8 3 2 2 2 8 7 1 8 3 5 2 0 9 3 5 3 9 6 5 7 2 5 1 2 1 0 8 3 5 7 9 1 5 1 3 6 9 8 8 2 0 9 1 4 4 4 2 1 0 0 6 7 5 1 0 3 3 4 6 7 1 1 0 3 1 4 1 2 6 7 1 1 1 3 6 9 9 0 8 6 5 8 5 1 6 3 9 8 3 1 5 0 1 9 7 0 1 6 5 1 5 1 1 6 8 5 1 7 1 4 3 7 6 5 7 6 1 8 3 5 1 5 5 6 5 0 8 8 4 9 0 9 9 8 9 8 5 9 9 8 2 3 8 7 3 4 5 5 2 8 3 3 1 6 3 5 5 0 7 6 4 7 9 1 8 5 3 5 8 9 3 2 2 6 1 8 5 4 8 9 6 3 2 1 3 2 9 3 3 0 8 9 8 5 7 0 6 4 2 0 4 6 7 5 2 5 9 0 7 0 9 1 5 4 8 1 4 1 6 5 4 9 8 5 9 4 6 1 6 3 7 1 8 0 2 7 0 9 8 1 9 9 4 3 0 9 9 2 4 4 8 8 9 5 7 5 7 1 2 8 2 8 9 0 5 9 2 3 2 3 3 2 6 0 9 7 2 9 9 7 1 2 0 8 4 4 3 3 5 7 3 2 6 5 4 8 9 3 8 2 3 9 1 1 9 3 2 5 9 7 4 6 3 6 6 7 3 0 5 8 3 6 0 4 1 4 2 8 1 3 8 8 3 0 3 2 0 3 8 2 4 9 0 3 7 5 8 9 8 5 2 4 3 7 4 4 1 7 0 2 9 1 3 2 7 6 5 6 1 8 0 9 3 7 7 3 4 4 4 0 3 0 7 0 7 4 6 9 2 1 1 2 0 1 9 1 3 0 2 0 3 3 0 3 8 0 1 9 7 6 2 1 1 0 1 1 0 0 4 4 9 2 9 3 2 1 5 1 6 0 8 4 2 4 4 4 8 5 9 6 3 7 6 6 9 8 3 8 9 5 2 2 8 6 8 4 7 8 3 1 2 3 5 5 2 6 5 8 2 1 3 1 4 4 9 5 7 6 8 5 7 2 6 2 4 3 3 4 4 1 8 9 3 0 3 9 6 8 6 4 2 6 2 4 3 4 1 0 7 7 3 2 2 6 9 7 8 0 2 8 0 7 3 1 8 9 1 5 4 4 1 1 0 1 0 4 4 6 8 2 3 2 5 2 7 1 6 2 0 1 0 5 2 6 5 2 2 7 2 1 1 1 6 6 0 3 9 6 6 6 5 5 7 3 0 9 2 5 4 7 1 1 0 5 5 7 8 5 3 7 6 3 4 6 6 8 2 0 6 5 3 1 0 9 8 9 6 5 2 6 9 1 8 6 2 0 5 6 4 7 6 9 3 1 2 5 7 0 5 8 6 3 5 6 6 2 0 1 8 5 5 8 1 0 0 7 2 9 3 6 0 6 5 9 8 7 6 4 8 6 1 1 7 9 1 0 4 5 3 3 4 8 8 5 0 3 4 6 1 1 3 6 5 7 6 8 6 7 5 3 2 4 9 4 4 1 6 6 8 0 3 9 6 2 6 5 7 9 7 8 7 7 1 8 5 5 6 0 8 4 5 5 2 9 6 5 4 1 2 6 6 5 4 0 8 5 3 0 6 1 4 3 4 4 4 3 1 8 5 8 6 7 6 9 7 5 1 4 5 6 6 1 4 0 6 8 0 0 7 0 0 2 3 7 8 7 7 6 5 9 1 3 4 4 0 1 7 1 2 7 4 9 4 7 0 4 2 0 5 6 2 2 3 0 5 3 8 9 9 4 5 6 1 3 1 4 0 7 1 1 2 7 0 0 0 4 0 7 8 5 4 7 3 3 2 6 9 9 3 9 0 8 1 4 5 4 6 6 4 6 4 5 8 8 0 7 9 7 2 7 0 8 2 6 6 8 3 0 6 3 4 3 2 8 5 8 7 8 5 6 9 8 3 0 5 2 3 5 8 0 8 9 3 3 0 6 5 7 5 7 4 0 6 7 9 5 4 5 7 1 6 3 7 7 5 2 5 4 2 0 2 1 1 4 9 5 5 7 6 1 5 8 1 4 0 0 2 5 0 1 2 6 2 2 8 5 9 4 1 3 0 2 1 6 4 7 1 5 5 0 9 7 9 2 5 9 2 3 0 9 9 0 7 9 6 5 4 7 3 7 6 1 2 5 5 1 7 6 5 6 7 5 1 3 5 7 5 1 7 8 2 9 6 6 6 4 5 4 7 7 9 1 7 4 5 0 1 1 2 9 9 6 1 4 8 9 0 3 0 4 6 3 9 9 4 7 1 3 2 9 6 2 1 0 7 3 4 0 4 3 7 5 1 8 9 5 7 3 5 9 6 1 4 5 8 9 0 1 9 3 8 9 7 1 3 1 1 1 7 9 0 4 2 9 7 8 2 8 5 6 4 7 5 0 3 2 0 3 1 9 8 6 9 1 5 1 4 0 2 8 7 0 8 0 8 5 9 9 0 4 8 0 1 0 9 4 1 2 1 4 7 2 2 1 3 1 7 9 4 7 6 4 7 7 7 2 6 2 2 4 1 4 2 5 4 8 5 4 5 4 0 3 3 2 1 5 7 1 8 5 3 0 6 1 4 2 2 8 8 1 3 7 5 8 5 0 4 3 0 6 3 3 2 1 7 5 1 8 2 9 7 9 8 6 6 2 2 3 7 1 7 2 1 5 9 1 6 0 7 7 1 6 6 9 2 5 4 7 4 8 7 3 8 9 8 6 6 5 4 9 4 9 4 5 0 1 1 4 6 5 4 0 6 2 8 4 3 3 6 6 3 9 3 7 9 0 0 3 9 7 6 9 2 6 5 6 7 2 1 4 6 3 8 5 3 0 6 7 3 6 0 9 6 5 7 1 2 0 9 1 8 0 7 6 3 8 3 2 7 1 6 6 4 1 6 2 7 4 8 8 8 8 0 0 7 8 6 9 2 5 6 0 2 9 0 2 2 8 4 7 2 1 0 4 0 3 1 7 2 1 1 8 6 0 8 2 0 4 1 9 0 0 0 4 2 2 9 6 6 1 7 1 1 9 6 3 7 7 9 2 1 3 3 7 5 7 5 1 1 4 9 5 9 5 0 1 5 6 6 0 4 9 6 3 1 8 6 2 9 4 7 2 6 5 4 7 3 6 4 2 5 2 3 0 8 1 7 7 0 3 6 7 5 1 5 9 0 6 7 3 5 0 2 3 5 0 7 2 8 3 5 4 0 5 6 7 0 4 0 3 8 6 7 4 3 5 1 3 6 2 2 2 2 4 7 7 1 5 8 9 1 5 0 4 9 5 3 0 9 8 4 4 4 8 9 3 3 3 0 9 6 3 4 0 8 7 8 0 7 6 9 3 2 5 9 9 3 9 7 8 0 5 4 1 9 3 4 1 4 4 7 3 7 7 4 4 1 8 4 2 6 3 1 2 9 8 6 0 8 0 9 9 8 8 8 6 8 7 4 1 3 2 6 0 4 7 2… (συνεχίζεται…!)

Το κόσκινο του Ερατοσθένη

Ο Ερατοσθένης (Κυρήνη 276 π.Χ. – Αλεξάνδρεια 194 π.Χ.) ήταν αρχαίος Έλληνας μαθηματικός, γεωγράφος, αστρονόμος, γεωδαίτης, ιστορικός και φιλόλογος. Θεωρείται ο πρώτος που υπολόγισε το μέγεθος της Γης και κατασκεύασε ένα σύστημα συντεταγμένων με παράλληλους και μεσημβρινούς. Ακόμα κατασκεύασε ένα χάρτη του κόσμου όπως τον θεωρούσε. Για τις θεωρίες του περί γεωγραφίας κατηγορήθηκε αργότερα από τον Στράβωνα, ότι δεν παρείχε τις αναγκαίες αποδείξεις.

Ερατοσθένης ο Κυρηναίος ανακάλυψε μια μέθοδο για να υπολογίζει τους πρώτους αριθμούς. Το ‘κόσκινό’ του ήταν μια σπουδαία ανακάλυψη για την εποχή του και ένα από τα μεγάλα επιτεύγματα του σημαντικού αυτού προσώπου.

Ο αλγόριθμος εμφανίζει όλους τους πρώτους αριθμούς από το 2 (1ος πρώτος) μέχρι ένα δεδομένο ακέραιο n. Εμφανίζουμε το 2 και διαγράφουμε όλα τα πολλαπλάσιά του. Στη συνέχεια εμφανίζουμε τον επόμενο διαθέσιμο αριθμό και διαγράφουμε όλα τα πολλαπλάσιά του. Η διαδικασία επαναλαμβάνεται μέχρι το τετράγωνο κάποιου αριθμού που εμφανίσαμε να ξεπερνά το n. Και όλοι οι υπόλοιποι αριθμοί που δεν διαγράφηκαν είναι πρώτοι.

Το κόσκινο του Ερατοσθένη σε ψευδογλώσσα:

Αλγόριθμος ΤοΚόσκινοΤουΕρατοσθένη
 Αρχή_επανάληψης
  Διάβασε n
 μέχρις_ότου n>1
 Για i από 2 μέχρι n
  Α[i]  ΑΛΗΘΗΣ
 Τέλος_επανάληψης
 Για i από 2 μέχρι Τ_Ρ(n) !Τετραγωνική Ρίζα του n
  Αν Α[i]=ΑΛΗΘΗΣ τότε
   j  i^2
   λ  1
   Όσο j<=n επανάλαβε
    Α[j]  ΨΕΥΔΗΣ
    j  i^2+λ*i
    λ  λ+1
   Τέλος_επανάληψης
  Τέλος_αν
 Τέλος_επανάληψης
 Για i από 2 μέχρι n
  Αν Α[i]=ΑΛΗΘΗΣ τότε
   Εμφάνισε i
  Τέλος_αν
 Τέλος_επανάληψης
Τέλος ΤοΚόσκινοΤουΕρατοσθένη

Ο αλγόριθμος του Ευκλείδη

Ο Ευκλείδης από την Αλεξάνδρεια (~ 325 π.Χ. – 265 π.Χ.), ήταν Έλληνας μαθηματικός, που δίδαξε και πέθανε στην Αλεξάνδρεια της Αιγύπτου, περίπου κατά την διάρκεια της βασιλείας του Πτολεμαίου Α΄ (323 π.Χ. – 283 π.Χ.). Στις μέρες μας είναι γνωστός ως ο «πατέρας» της Γεωμετρίας.

Εφηύρε έναν αλγόριθμο για τον υπολογισμό του Μεγίστου Κοινού Διαιρέτη (Greatest Common Divisor – GCD) δύο ακεραίων α, β. GCD(α,β).

Απέδειξε ότι:

GCD(α,β) = GCD(β,α MOD β)

Όπου MOD είναι το modulo, δηλαδή το υπόλοιπο της ακέραιας διαίρεσης.

Με αποτέλεσμα να προκύψει ο εξής αλγόριθμος:

Αλγόριθμος Ευκλείδης
 Διάβασε α, β
 Αν α>β τότε
  max  α
  min  β
 Αλλιώς
  max  β
  min  α
 Τέλος_αν
 υ  max MOD min
 Όσο υ>0 επανάλαβε
  temp  max
  max  min
  min  temp MOD min
  υ  min
 Τέλος_επανάληψης
 Εμφάνισε max
Τέλος Ευκλείδης

 

Ο παραπάνω αλγόριθμος θα μπορούσε να γίνει ως εξής με χρήση αναδρομής (ricursion):

ΣΥΝΑΡΤΗΣΗ gcd(α,β): ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β, Υ
ΑΡΧΗ
 Υ  max(α,β) MOD min(α,β)
 ΑΝ Υ=0 ΤΟΤΕ
  gcd  min(α,β)
 ΑΛΛΙΩΣ
  gcd  gcd(min(α,β), max(α,β) MOD min(α,β))
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ max(α,β): ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
ΑΡΧΗ
 ΑΝ α>β ΤΟΤΕ
  max  α
 ΑΛΛΙΩΣ
  max  β
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ min(α,β): ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
ΑΡΧΗ
 ΑΝ α<β ΤΟΤΕ
  min  α
 ΑΛΛΙΩΣ
  min  β
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

Το άθροισμα του Gauss

Ο Johann Carl Friedrich Gauss γεννήθηκε στις 30 Απριλίου 1777 και πέθανε στις 23 Φεβρουαρίου 1855. Ήταν γερμανός μαθηματικός που συνεισέφερε σε πολλά ερευνητικά πεδία της επιστήμης του, όπως η θεωρία αριθμών, η στατιστική, η μαθηματική ανάλυση, η διαφορική γεωμετρία, αλλά και συναφών επιστημών, όπως η γεωδαισία, η αστρονομία και η φυσική (ηλεκτροστατική, οπτική, γεωμαγνητισμός).

Όταν ήταν 10 μόλις ετών, μαθητής δημοτικού, ο δάσκαλος ζήτησε από την τάξη να υπολογίσουν το άθροισμα από το 1 ως το 100 (1+2+3+…+100). Εικάζουμε ότι ο δάσκαλος είχε δουλειά και θέλησε να απασχολήσει για ώρα τους μαθητές. Ο δάσκαλος δεν πέτυχε το σκοπό του, αφού ο Gauss σε λίγα δευτερόλεπτα απάντησε το αποτέλεσμα 5050!

Ας δούμε τι σκέφτηκε ο Gauss.

Το ζητούμενο ήταν:

S=1+2+3+...+98+99+100

Με βάση την αντιμεταθετική ιδιότητα (που τότε δεν τη γνώριζε φυσικά):

S=(1+100)+(2+99)+(3+98)+...

Άρα:

S=101+101+101+...

Δεδομένου ότι έπαιρνε τους αριθμούς ανα ζεύγη και τα ζεύγη του συνόλου [1,100] είναι 50:

S = 50 x 101= 5050

Αν δε γνωρίζαμε το Gauss θα ακολουθούσαμε την εξαντλητική μέθοδο, που αλγοριθμικά εκφράζεται ως εξής:

Αλγόριθμος WithoutGauss
 S  0
 Για i από 1 μέχρι 100
  S  S + i
 Τέλος_επανάληψης
 Εμφάνισε S
Τέλος WithoutGauss

 

Γενικεύοντας για οποιουδήποτε μήκους σειρά που ξεκινά από το 1 ο Gauss μας έδωσε το εξής:

Αλγόριθμος Gauss
 Διάβασε Ν  !όπου Ν είναι το μήκος της σειράς
 S  (N+1)*(N/2)
 Εμφάνισε S
Τέλος Gauss

Το παράδοξο των γενεθλίων

Αν μαζεύατε σε μια αίθουσα 23 άτομα και τους λέγατε να γράψουν σε ένα πίνακα την ημέρα που έχουν γενέθλια, όσο απίθανο κι αν ακούγεται,  η πιθανότητα να εμφανιστεί δύο φορές η ίδια ημερομηνία στον πίνακα είναι μεγαλύτερη από 50%. Αν τα άτομα γίνουν 41, η πιθανότητα γίνεται μεγαλύτερη από 90% και τέλος στα 57 άτομα γίνεται 99%!

Ας θεωρήσουμε P(A) την πιθανότητα να υπάρχουν 2 άτομα με ίδια ημέρα γενεθλίων. Συνεπώς, η P(A’) είναι η πιθανότητα να  μην υπάρχουν.

P(A')=1-P(A)

Για ένα άτομο η πιθανότητα είναι 365/365=1 δηλαδή 100%. Για το δεύτερο άτομο η πιθανότητα να μην έχει ίδια ημέρα γενέθλια με το πρώτο είναι 364/365. Για το τρίτο άτομο είναι 363/365.

P(A')=365/365×364/365×363/365×...×343/365 =>
P(A') = 0.49270276

Άρα η πιθανότητα που μας ενδιέφερε θα είναι:

P(A) = 1 − 0.49270276 = 0.507297

Δηλαδή 50,7%!

Άτομα Πιθανότητα
5 2.7%
10 11.7%
15 25.3%
20 41.1%
23 50.7%
30 70.6%
40 89.1%
50 97.0%
57 99.0%
100 99.99997%
200 99,9999999999999999999999999998%

Ο αλγόριθμος για τον υπολογισμό πιθανότητας για άτομα Ν είναι ο εξής:

Αλγόριθμος BirthdayParadox
 Εμφάνισε "Δώστε πλήθος ατόμων..."
 Διάβασε Ν
 Ρτόνος  1
 Για i από 1 μέχρι Ν
  Pτόνος  Pτόνος*(366-i)/365
 Τέλος_επανάληψης
 P  (1-Pτόνος)*100
 Εμφάνισε "Στα ",N," άτομα η πιθανότητα είναι ",P,"%"
Τέλος BirthdayParadox
 

Ο Αλγόριθμος του Goethe

Το 1797 ο Goethe ήθελε να πουλήσει τα πνευματικά δικαιώματα του έπους του Χέρμαν και Δωροθέα στον εκδότη Vieweg.

Εικάζεται ότι ο Goethe ήθελε να μάθει πόσα ο εκδότης περίμενε ότι θα έβγαζε από το έργο του.

Προφανώς δεν θα το μάθαινε αυτό ρωτώντας τον εκδότη, διότι αυτός θα είχε κίνητρο να μην αποκαλύψει το πραγματικό του κέρδος στον Goethe από φόβο ότι θα πληρώσει ακριβά για τα δικαιώματα.

Έστειλε λοιπόν ο Goethe στον εκδότη το εξής γράμμα:

Σχετικά με τα δικαιώματα θα προχωρήσουμε ως εξής: Θα δώσω στον κύριο Boettiger ένα κλειστό φάκελο που περιέχει πόσα εγώ ζητάω, και θα περιμένω μια προσφορά για το έργο μου από τον κύριο Vieweg. Αν η προσφορά του είναι κάτω από όσα ζητάω θα αποσύρω το φάκελό μου και η διαπραγμάτευση σταματάει. Διαφορετικά, η ανάθεση θα γίνει και ο κύριος Vieweg δεν θα πληρώσει την προσφορά του, αλλά ότι είναι γραμμένο στο φάκελο τον οποίο θα ανοίξει ο κύριος Boettiger.

Al-Khwarizmi – ο, εν αγνοία του, εφευρέτης και νονός του Αλγορίθμου

Ο Abu Ja’far Muhammad ibn Musa Al-Khwarizmi ήταν πέρσης μαθηματικός, αστρονόμος και γεωγράφος. Γεννήθηκε το 780 μ.Χ. στη Χορασμία και πέθανε το 850 μ.Χ. στη Βαγδάτη.

Ήταν ο πρώτος που χρησιμοποίησε τον αριθμό 0, ως τέλος των αρνητικών και αρχή των θετικών αριθμών. Επίσης, σ’ αυτόν οφείλουμε και τον αλγόριθμο επίλυσης των δευτεροβάθμιων εξισώσεων.

Οι συνεισφορές του είχαν μεγάλο αντίκτυπο και στη γλώσσα. Η λέξη «Άλγεβρα» προέρχεται από το Αλ-γκιαμπρ μια από τις δύο πράξεις που χρησιμοποιούσε για την επίλυση δευτεροβάθμιων εξισώσεων.

Ο όρος Αλγόριθμος προέρχεται από το Algoritmi (Αλγκορίτμι), το Λατινικό του όνομα.  Η Ισπανική λέξη guarismo και η πορτογαλική algarismo προέρχονται από το όνομα του, και οι δυο λέξεις σημαίνουν ψηφίο.

Όπως πολύ εύστοχα ανέφερε ο Κωνσταντίνος Δασκαλάκης (Καθηγητής Πληροφορικής στο MIT) σε μια διάλεξή του στο «The Hub Events», o Al Khwarizmi είναι πολύ πιθανό σήμερα, να μην έπαιρνε visa για μια επίσκεψή του στην Αμερική.