Ακέραια διαίρεση – λύση

ΣΥΝΑΡΤΗΣΗ Diver(a,b):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b, ΠΗΛΙΚΟ
ΑΡΧΗ
 ΠΗΛΙΚΟ  0
 ΟΣΟ a>b ΕΠΑΝΑΛΑΒΕ
  a  a - b
  ΠΗΛΙΚΟ  ΠΗΛΙΚΟ + 1
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 Diver  ΠΗΛΙΚΟ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ Moder(a,b):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b, ΠΗΛΙΚΟ
ΑΡΧΗ
 ΠΗΛΙΚΟ  0
 ΟΣΟ a>b ΕΠΑΝΑΛΑΒΕ
  a  a - b
  ΠΗΛΙΚΟ  ΠΗΛΙΚΟ + 1
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 Moder  a
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Ασφάλεια Πληροφοριακών Συστημάτων – Λύση

1. Διαδικασία…

ΔΙΑΔΙΚΑΣΙΑ ΒΑΘΜΟΣ(Β)
 ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Β
ΑΡΧΗ
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  ΔΙΑΒΑΣΕ Β
 ΜΕΧΡΙΣ_ΟΤΟΥ Β>=0 ΚΑΙ Β<=10
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

2. Συνάρτηση…

ΣΥΝΑΡΤΗΣΗ ΤΒ(Α, Β, Γ, ΠΡ, ΤΕΞ):ΠΡΑΓΜΑΤΙΚΗ
 ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α, Β, Γ, ΠΡ, ΤΕΞ
ΑΡΧΗ
 ΑΝ ΤΕΞ<5 ΤΟΤΕ
  ΤΒ  0.1*(Α+Β+Γ)+0.15*ΠΡ+0.55*ΤΕΞ
 ΑΛΛΙΩΣ
  ΤΒ  0.06*(Α+Β+Γ)+0.12*ΠΡ+0.7*ΤΕΞ
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

3. Κυρίως Πρόγραμμα…

ΠΡΟΓΡΑΜΜΑ ΨΗΣΥΣ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΛ, ΤΕΛΙΚΟΙ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ, ΜΑΧΟΝ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α1, Α2, Α3, ΠΡ, Μ, ΤΕΞ, ΤΕΛ, ΜΑΧ, ΠΟΣ
ΑΡΧΗ
 ΠΛ  0
 ΤΕΛΙΚΟΙ  0
 ΔΙΑΒΑΣΕ ΟΝ
 ΟΣΟ ΟΝ<>' ' ΕΠΑΝΑΛΑΒΕ
  ΠΛ  ΠΛ+1
  ΚΑΛΕΣΕ Β(Α1)
  ΚΑΛΕΣΕ Β(Α2)
  ΚΑΛΕΣΕ Β(Α3)
  ΚΑΛΕΣΕ Β(ΠΡ)
  Μ  (Α1+Α2+Α3+Μ)/4
  ΑΝ Μ>=5 ΤΟΤΕ
   ΚΑΛΕΣΕ Β(ΤΕΞ)
   ΤΕΛ  ΤΒ(Α1,Α2,Α3,ΠΡ,ΤΕΞ)
   ΓΡΑΨΕ ΟΝ, ΤΕΛ
  ΑΛΛΙΩΣ
   ΤΕΛΙΚΟΙ  ΤΕΛΙΚΟΙ + 1
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΠΛ=1 Ή ΠΡ>ΜΑΧ ΤΟΤΕ
   ΜΑΧ  ΠΡ
   ΜΑΧΟΝ  ΟΝ
  ΤΕΛΟΣ_ΑΝ
  ΔΙΑΒΑΣΕ ΟΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ ΠΛ<>0 ΤΟΤΕ
  ΠΟΣ  (ΤΕΛΙΚΟΙ*100)/ΠΛ
  ΓΡΑΨΕ 'Το ποσοστό των επιτυχόντων είναι ', ΠΟΣ*100, '%'
  ΓΡΑΨΕ 'Το μεγαλύτερο βαθμό στην Πρόοδο είχε ο ', ΜΑΧΟΝ
 ΑΛΛΙΩΣ
  ΓΡΑΨΕ 'Δεν δόθηκε κανένα όνομα'
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Αλγόριθμος Σχολείο – Λύση

Αλγόριθμος Σχολείο
 Για i από 1 μέχρι 20     !ερώτημα 1
  Διάβασε ΕΠ[i,j], ON[i,j]
 Τέλος_επανάληψης
 Για j από 1 μέχρι 10     !ερώτημα 2
  Διάβασε ΤΙΤ[j]
 Τέλος_επανάληψης
 Για i από 1 μέχρι 20     !ερώτημα 3
  Για j από 1 μέχρι 10
   Διάβασε ΒΑΘ[i,j]
  Τέλος_επανάληψης
 Τέλος_επανάληψης
 k  0          !ερώτημα 4
 Για i από 1 μέχρι 20
  Αν ΕΠ[i]="Παπαδόπουλος" τότε
   k  k + 1
   s  0
   Για j από 1 μέχρι 10
    s  s + ΒΑΘ[i,j]
   Τέλος_επανάληψης
   ΜΟΠΑΠ[k]  s/10
   ΟΝΠΑΠ[k]  ON[i]
  Τέλος_αν
 Τέλος_επανάληψης
 Αν k>0 τότε
  Για i από 2 μέχρι k
   Για j από k μέχρι i με_βήμα -1
    Αν ΟΝΠΑΠ[j]<ΟΝΠΑΠ[j-1] τότε
     temp  ΟΝΠΑΠ[j]
     ΟΝΠΑΠ[j]  ΟΝΠΑΠ[j-1]
     ΟΝΠΑΠ[j-1]  temp
     temp2  ΜΟΠΑΠ[j]
     ΜΟΠΑΠ[j]  ΜΟΠΑΠ[j-1]
     ΜΟΠΑΠ[j-1]  temp2
    Τέλος_αν
   Τέλος_επανάληψης
  Τέλος_επανάληψης
  Για i από 1 μέχρι k
   Εμφάνισε "Παπαδόπουλος ", ΟΝΠΑΠ[i], " ", ΜΟΠΑΠ[i]
  Τέλος_επανάληψης
 Αλλιώς
  Εμφάνισε "Δεν υπάρχει Παπαδόπουλος"
 Τέλος_αν
 Για j από 1 μέχρι 10      !ερώτημα 5
  Αν ΤΙΤ[j]="Έκθεση" τότε
   ΜΙΝ  ΒΑΘ[1,j]
   θ  1
   Για i από 2 μέχρι 20
    Αν ΒΑΘ[i,j]<MIN τότε
     ΜΙΝ  ΒΑΘ[i,j]
     θ  i
    Τέλος_αν
   Τέλος_επανάληψης
   Εμφάνισε ΟΝ[θ], " ", ΕΠ[θ]
  Τέλος_αν
 Τέλος_επανάληψης
 Για j από 1 μέχρι 10     !ερώτημα 6
  s  0
  Για i από 1 μέχρι 20
   s  s + ΒΑΘ[i,j]
  Τέλος_επανάληψης
  Εμφάνισε ΤΙΤ[j], ": ", s/20
 Τέλος_επανάληψης
 πλ  0      !ερώτημα 7
 Για i από 1 μέχρι 20
  πλ20  0
  Για j από 1 μέχρι 10
   Αν ΒΑΘ[i,j]=20 τότε
    πλ20  πλ20 + 1
   Τέλος_αν
  Τέλος_επανάληψης
  Αν πλ20>5 τότε
   πλ  πλ + 1
  Τέλος_αν
 Τέλος_επανάληψης
 Εμφάνισε πλ
Τέλος Σχολείο
   
 

Συγχώνευση 1 – Λύση

Κυρίως Πρόγραμμα…

ΠΡΟΓΡΑΜΜΑ Συγχώνευση
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΜΘ, ΜΤ, i, j, k, z
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ, ΚΑΤ, Γ2[32], Γ3[32], Γ23[32]
 ΑΡΧΗ
  ΜΘ  1
  ΜΤ  1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 32
   ΔΙΑΒΑΣΕ ΟΝ
   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΚΑΤ
   ΜΕΧΡΙΣ_ΟΤΟΥ ΚΑΤ='τεχνολογική' Ή ΚΑΤ='θετική'
   ΑΝ ΚΑΤ='τεχνολογική' ΤΟΤΕ
    Γ2[ΜΤ]  ΟΝ
    ΜΤ  ΜΤ + 1
   ΑΛΛΙΩΣ
    Γ3[ΜΘ]  ΟΝ
    ΜΘ  ΜΘ + 1
   ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΑΛΕΣΕ ΑΒ(Γ2, ΜΤ - 1)
  ΚΑΛΕΣΕ ΑΒ(Γ3, ΜΘ - 1)
  i  1
  j  1
  k  1
  ΟΣΟ (i<=MT - 1) KAI (j<=ΜΘ - 1) ΕΠΑΝΑΛΑΒΕ
   ΑΝ Γ2[i]<Γ3[j] ΤΟΤΕ
    Γ23[k]  Γ2[i]
    i  i + 1
   ΑΛΛΙΩΣ
    Γ23[k]  Γ3[j]
    j  j + 1
   ΤΕΛΟΣ_ΑΝ
   k  k + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ i > MT - 1 ΤΟΤΕ
   ΓΙΑ z ΑΠΟ k ΜΕΧΡΙ 32
    Γ23[z]  Γ3[j]
    j  j + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΛΛΙΩΣ
   ΓΙΑ z ΑΠΟ k ΜΕΧΡΙ 32
    Γ23[z]  Γ2[i]
    i  i + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 32
   ΓΡΑΨΕ Γ23[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Διαδικασία…

ΔΙΑΔΙΚΑΣΙΑ ΑΒ(Π, Ν)
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, N, j
  ΧΑΡΑΚΤΗΡΕΣ: Π[32]
 ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν
   ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1
    ΑΝ Π[j] < Π[j-1] ΤΟΤΕ
     ΤΕΜΡ  Π[j]
     Π[j]  Π[j-1]
     Π[j-1]  TEMP
    ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

America’s Cup – Λύση

Κυρίως Πρόγραμμα…

ΠΡΟΓΡΑΜΜΑ AmericasCup
 ΜΕΤΑΒΛΗΤΕΣ   !ΕΡΩΤΗΜΑ 1
  ΑΚΕΡΑΙΕΣ: i, j, F[20,20], N[20], MAX, MIN, S
  ΧΑΡΑΚΤΗΡΕΣ: ON[20], Winner
  ΛΟΓΙΚΕΣ: flag
 ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20   !ΕΡΩΤΗΜΑ 2
   ΓΡΑΨΕ 'Δώστε το όνομα του ', i, 'ου σκάφους'
   ΔΙΑΒΑΣΕ ΟΝ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20   !ΕΡΩΤΗΜΑ 3
   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ i=j ΤΟΤΕ
     F[i,j] -1
    ΑΛΛΙΩΣ
     ΔΙΑΒΑΣΕ F[i,j]
    ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΑΛΕΣΕ ΝίκηΑνάΣκάφος(F,N) !ΕΡΩΤΗΜΑ 4
  MAX  N[1]    !ΕΡΩΤΗΜΑ 5
  Winner  ON[1]
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
   ΑΝ Ν[i]>MAX ΤΟΤΕ
    ΜΑΧ  Ν[i]
    Winner  ON[i]
   ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Νίκησε το σκάφος: ', Winner
  MIN  F[1,2]    !ΕΡΩΤΗΜΑ 6
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ i<>j ΤΟΤΕ !ή ισοδύναμα F[i,j]<>-1
     ΑΝ F[i,j]< MIN ΤΟΤΕ
      ΜΙΝ  F[i,j]
     ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 20 !ΕΡΩΤΗΜΑ 7
   flag  ΨΕΥΔΗΣ
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ F[i,j]=MIN ΤΟΤΕ
     flag  ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΑΝ flag=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ ΟΝ[j]
   ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 20    !ΕΡΩΤΗΜΑ 8
   ΑΝ ΟΝ[j]='ALINGHI' ΤΟΤΕ
    S  0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ i<>j ΤΟΤΕ
      S  S + F[i,j]
     ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Το Alinghi δέχτηκε ',S ' fouls'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Διαδικασία…

ΔΙΑΔΙΚΑΣΙΑ ΝίκηΑνάΣκάφος (F, N)   !ΕΡΩΤΗΜΑ 9
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, N[20], j, F[20,20]
 ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
   Ν[i]  0
   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ i<>j ΤΟΤΕ
     ΑΝ F[i,j]<=F[j,i] TOTE
      N[i]  N[i] + 1
     ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ