Ακέραια διαίρεση

Γνωρίζουμε ότι η «ΓΛΩΣΣΑ» διαθέτει τους τελεστές DIV και MOD για τον υπολογισμό του πηλίκου της ακέραιας διαίρεσης και του υπολοίπου αντίστοιχα. Σε αυτή την άσκηση καλείστε να τους αγνοήσετε!
Να υλοποιήσετε δύο συναρτήσεις με ονόματα Diver και Moder που θα παίρνουν σαν ορίσματα δύο ακέραιους αριθμούς και θα επιστρέφουν η μια το πηλίκο και οι άλλη το υπόλοιπο.

Διευκρίνιση: Από σύμβαση θεωρούμε ότι και οι δύο αριθμοί είναι ακέραιοι και ότι ο πρώτος είναι διαιρετέος και ο δεύτερος διαιρέτης.

Η λύση εδώ

Τι θα δείξει η οθόνη 1

Τι θα εκτυπώσει το παρακάτω πρόγραμμα αν δοθούν ως αρχικές τιμές στην εντολή ΔΙΑΒΑΣΕ Α, Β, Γ οι τιμές 6, 3, 5 αντίστοιχα;

ΠΡΟΓΡΑΜΜΑ ΤΑΔΕ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Γ
  ΛΟΓΙΚΕΣ: ΤΙΜΗ
 ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α, Β, Γ
  ΓΡΑΨΕ Α, Β, Γ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   ΚΑΛΕΣΕ Δ1(Α, Β, Γ, ΤΙΜΗ)
   ΓΡΑΨΕ Α, Β, Γ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΤΙΜΗ = ΑΛΗΘΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Δ1(Γ, Β, Α, ΤΙΜΗ)
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Γ
  ΠΡΑΓΜΑΤΙΚΕΣ: Χ
  ΛΟΓΙΚΕΣ: ΤΙΜΗ
 ΑΡΧΗ
  Χ  2*Γ MOD (Β + Α)
  ΓΡΑΨΕ Χ
  ΤΙΜΗ  ΥΠΟΛΟΓΙΣΜΟΣ (Χ, Γ)
  Γ  Γ + 2
  Α  Α + 1
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΥΠΟΛΟΓΙΣΜΟΣ (Ζ, Β):ΛΟΓΙΚΗ
 ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Β
  ΠΡΑΓΜΑΤΙΚΕΣ: Ζ, Υ
 ΑΡΧΗ
  Υ  Ζ - Α_Μ(Β/2)
  ΑΝ Υ>0 ΤΟΤΕ
   ΥΠΟΛΟΓΙΣΜΟΣ  ΑΛΗΘΗΣ
  ΑΛΛΙΩΣ
   ΥΠΟΛΟΓΙΣΜΟΣ  ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

Η λύση εδώ