Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

Πανελλαδικές 2015 – Ημερήσιο Γενικό Λυκειο

M.Sc. Νίκος Παπαθεοδούλου – ΠΕ19 – npapath@gmail.com

Θέμα Α

Α1. 1 = Σ, 2 = Σ, 3 = Λ, 4 = Σ, 5 = Λ

Α2.α υπολογιστικά, απόφασης, βελτιστοποίησης

Α2.β 1. βελτιστοποίησης, 2. απόφασης, 3. υπολογιστικό

Α3.α Απαιτούνται 2 δείκτες, ο front και ο rear. Ο front μας δείχνει τη θέση του στοιχείου που είναι έτοιμο για εξαγωγή και ο rear τη θέση του στοιχείου που μόλις εισήλθε.

Α3.β Ο δείκτης front, ο οποίος αυξάνεται κατά ένα.

Α4.α

λ  λ + 2

 

Α4.β

Αν Χ > Υ τότε
  Αν Υ <> 1 τότε
    Ζ  Χ/(Υ-1)
  Αλλιώς
    Ζ  Υ/Χ
  Τέλος_αν
  Εμφάνισε Ζ
Τέλος_αν

 

Α5.α.
1.
ΧΧ + 2
2. Y(K+Λ+Μ)/3
3. A MOD 10 = 5
4. (B>=10)KAI(B<=99)

Α5.β.
1.
Η εντολή: Γράψε 22. Γράψε 1 στο Χ>15 – Γράψε 3 στο Χ<=15

Θέμα Β

Β1.α

B1.β

Αν Χ > 1 τότε
  Για Υ από Χ-2 μέχρι 0 με_βήμα -2
    Εμφάνισε Υ
  Τέλος_επανάληψης
Τέλος_αν

 

Β2. (1): 1 , (2): 2 , (3): 100 , (4): i , (5): > , (6): i – 1

Θέμα Γ

Γ.1.

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ
  ΜΕΤΑΒΛΗΤΕΣ
    ΠΡΑΓΜΑΤΙΚΕΣ: ΕΛΑ, ΕΛΒ, ΔΕΜ
    ΑΚΕΡΑΙΕΣ: ΠΛΔΑ, ΠΛΔΒ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ ΕΛΑ, ΕΛΒ
  ΠΛΔΑ  0
  ΠΛΔΒ  0
  ΔΙΑΒΑΣΕ ΔΕΜ
  ΟΣΟ ΔΕΜ <> 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΔΕΜ >ΕΛΑ ΚΑΙ ΔΕΜ > ΕΛΒ ΤΟΤΕ
      ΓΡΑΨΕ 'Προώθηση'
    ΑΛΛΙΩΣ
      ΑΝ ΕΛΑ >= ΕΛΒ ΤΟΤΕ
        ΕΛΑ  ΕΛΑ -ΔΕΜ
        ΠΛΔΑ  ΠΛΔΑ + 1
      ΑΛΛΙΩΣ
        ΕΛΒ  ΕΛΒ - ΔΕΜ
        ΠΛΔΒ  ΠΛΔΒ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΔΕΜ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΑΛΕΣΕ Γ2(ΠΛΔΑ, ΠΛΔΒ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Γ.2.

ΔΙΑΔΙΚΑΣΙΑ Γ2(Α, Β)
  ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
  ΑΝ Α <> 0 ΚΑΙ Β <> 0 ΤΟΤΕ
    ΑΝ Α > Β ΤΟΤΕ
      ΓΡΑΨΕ 'Α'
    ΑΛΛΙΩΣ_ΑΝ Β > Α ΤΟΤΕ
      ΓΡΑΨΕ 'Β'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ισάριθμα'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Καμία αποθήκευση στο αεροδρόμιο'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 

Θέμα Δ

Αλγόριθμος ΘέμαΔ
  Για i άπό 1 μέχρι 45
    Διάβασε ΤΙΤ[i]
    Για j από 1 μέχρι 7
      Διάβασε ΒΑΘ[i,j]
    Τέλος_επανάληψης
    sum[i]  0
    Για j από 1 μέχρι 7
      sum[i]  sum[i] + ΒΑΘ[i,j]
    Τέλος_επανάληψης
    Εμφάνισε ΤΙΤ[i], ":", sum[i], " βαθμοί"
  Τέλος_επανάληψης
  πλ  0
  Για i από 1 μέχρι 45
    πλ5  0
    Για j από 1 μέχρι 7
      Αν ΒΑΘ[i,j] >= 5 τότε
        πλ5  πλ5 + 1
      Τέλος_αν
    Τέλος_επανάληψης
    Αν πλ5 = 7 ΚΑΙ sum[i] > 50 τότε
      Εμφάνισε "Προκρίθηκε το: ", ΤΙΤ[i]
      πλ  πλ + 1
    Τέλος_αν
  Τέλος_επανάληψης
  Αν πλ = 0 τότε
    Εμφάνισε "Δεν προκρίθηκε κανένα"
  Τέλος_αν
  πλκ  0
  Για j από 1 μέχρι 7
    max[j]  ΒΑΘ[1,j]
    Για i από 2 μέχρι 45
      Αν ΒΑΘ[i,j] > max[j] τότε
        max[j]  ΒΑΘ[i,j]
      Τέλος_αν
    Τέλος_επανάληψης
    πλmax  0
    Για i από 1 μέχρι 45
      Αν ΒΑΘ[i,j] = max[j] τότε
        πλmax  πλmax + 1 
      Τέλος_αν
    Τέλος_επανάληψης
    Αν πλmax = 1 τότε
      πλκ  πλκ + 1
    Τέλος_αν
  Τέλος_επανάληψης
  Εμφάνισε πλκ
Τέλος ΘέμαΔ